Использование логических функций в табличном процессоре MS EXCEL



Задание 1.
Написать функцию «ЕСЛИ» для расчета оплаты электроэнергии. За первые 100 кВт клиент платит 2 руб. за 1 кВт, за превышение расхода свыше 100 кВт в месяц - по 2,5 руб. за каждый кВт.

A
B
C

1
Клиент
Кол-во электроэнергии
Оплата

2
Коржова
140


3
Давыдова
100


4
Козлов
80


5
Литвинов
50


6
Новиков
120


В ячейке С2 нужно записать следующую функцию: =ЕСЛИ(B2<=100;B2*2;B2*2,5)
Возможный вариант записи формулы: =ЕСЛИ(B2>100;B2*2,5;В2*2)
Задание 2.
Создать таблицу, выполнив словесную оценку результатов конкурсного отбора по результатам экзаменов «Принят» - «Не принят» («Принят» - если набрал не менее 12 баллов).

A
B
C
D
E
F
G

1





проходной балл
12


Ф.И.О
Математика
Физика
Русский язык
общая сумма баллов
результат решения



Исаченко
4
5
4
=СУММ(B3:D3)




Сумина
4
4
4
=СУММ(B4:D4)




Рябова
3
4
3
=СУММ(B5:D5)




Кузнецова
5
4
5
=СУММ(B6:D6)




Насонов
4
4
3
=СУММ(B7:D7)



Ячейка F3 содержит выражение: =ЕСЛИ(E3>=12;"принят";"не принят")
или возможный вариант: =ЕСЛИ(E3<12;"не принят";"принят")
13 SHAPE \* MERGEFORMAT 1415
Рассмотрим вложенную функцию «ЕСЛИ».
Задание 3.
Составить таблицу расчета оплаты за аренду помещений в зависимости от площади: если арендуемая площадь меньше 100 м2, то арендная плата составляет 500 руб. за 1 м2, если арендуемая площадь больше, чем 100 м2, но не превышает 200 м2 , то арендная плата составляет 700 руб. за 1 м2. За площадь более 200 м2 арендная плата – 800 руб. за 1 м2 .
Составляется таблица в следующем виде:
Кафе
Площадь (кв.м)
Сумма арендной платы

«Эдельвейс»
167


«Нарцисс»
95


«Камелот»
234


«Рандеву»
128


«Экспромт»
173


Для заполнения столбца вызывается мастер функций и записывается вложенная функция «ЕСЛИ», для удобства можно записывать ее в строке формул, соблюдая соответствующий синтаксис данной функции.

Итоговая таблица примет вид:
13 SHAPE \* MERGEFORMAT 1415
Возможный вариант записи функции «ЕСЛИ»:
=ЕСЛИ(B2>200;B2*800;ЕСЛИ(B2>100;B2*700;B2*500))
Задание 4.

Продуктовый склад отпускает муку и сахар для предприятий по оптовым ценам в зависимости от объема закупок.
Для муки используются следующие цены: более 10000 кг – по 12 руб. за 1кг, от 5000 до 10000 – по 13 руб. за 1кг, от 1000 до 5000 кг – по 14 руб. за 1кг, менее 1000 кг – по 15 руб. за 1 кг. Для сахара: более 5000 кг – 13 руб. за 1кг, от 3000 до 5000 кг – по 14 руб. за 1 кг, от 1000 до 3000 кг – по 16 руб. за 1 кг, менее 1000 кг – по 17 руб. за 1 кг. Рассчитайте стоимость муки и сахара, используя функцию ЕСЛИ; а также общую сумму стоимости этих продуктов для каждого предприятия.
Постройте: а) гистограмму, показывающую объем закупок муки для каждого предприятия; б) цилиндрическую диаграмму, показывающую общую сумму потраченных средств для каждого предпри

Приложенные файлы


Добавить комментарий