Презентация по информатике на тему Исполнитель черепашка и Черепашка меняет цвет (7 класс)


Чтобы посмотреть презентацию с картинками, оформлением и слайдами, скачайте ее файл и откройте в PowerPoint на своем компьютере.
Текстовое содержимое слайдов презентации:

АЛГОРИТМИЗАЦИЯ И ПРОГРАММИРОВАНИЕ Урок информатики в 7 классе Урок 1 Чей брат СЕРЕЖА? Выполните алгоритм Запишите слово 1 Замените первую букву на букву К 2 Выполните 3 раза задание п. 4 3 Уберите третью букву 4 Вставьте перед третьей буквой букву Ш 5 Ч 1. Каша, череп И 1. Лот, пень, и, лис. Из букв данных слов, переставив их, составьте термин, связанный с информатикой и компьютерами. Назовите тему урока ИСПОЛНИТЕЛЬ ЧЕРЕПАШКА Прекрасные возможности при обучении информатике предоставляет язык программирования ЛОГО, предложенный американским профессором Массачусетского технологического института Сеймуром Пейпертом в 1972 году ИСПОЛНИТЕЛЬ ЧЕРЕПАШКА Команды, которые умеет выполнять Черепашка ВПЕРЕД 50 ВП 50НАЗАД 50 НД 50НАЛЕВО 30 ЛВ 30НАПРАВО 90 ПР 90 На сколько шагов вперед? ПРОБЫ ПЕРА Управляют пером следующие команды ПО - перо опустиПП – перо поднимиСГ - сотри графику - экран очищается, а черепашка возвращается в исходное положение «домой» ПРОБЫ ПЕРА АЛГОРИТМИЗАЦИЯ И ПРОГРАММИРОВАНИЕ Черепашка меняет цвет Урок 2 ОТГАДАЙТЕ РЕБУС Два ребуса на одну тему ИСПОЛНИТЕЛЬ ОТГАДАЙТЕ РЕБУС Два ребуса на одну тему ЧЕРЕПАШКА ВСЕ ПОВТОРЯЕТСЯ Ц 1. Многократное повторение команд2. Алгоритм – «Попугай» По приведенным ниже шуточным определениям найдите соответствующий термин, связанный с темой прошлого урока и темой урока сегодня. КАРТИНЫ ИЗ ЖИЗНИ ЧЕРЕПАХИ Что нарисует Черепашка, выполнив следующие команды: по повтори 3 [вп 100 пр 360 / 3]пп А КАРТИНЫ ИЗ ЖИЗНИ ЧЕРЕПАХИ Что нарисует Черепашка, выполнив следующие команды: по повтори 10 [вп 100 пр 360 / 5]пп Б КАРТИНЫ ИЗ ЖИЗНИ ЧЕРЕПАХИ Что нарисует Черепашка, выполнив следующие команды: по повтори 6 [вп 150 пр 360 / 6]пп В КАРТИНЫ ИЗ ЖИЗНИ ЧЕРЕПАХИ Что нарисует Черепашка, выполнив следующие команды: по повтори 360 [вп 1 пр 360 / 360]пп Г КАРТИНЫ ИЗ ЖИЗНИ ЧЕРЕПАХИ КАРТИНЫ ИЗ ЖИЗНИ ЧЕРЕПАХИ ПАЛИТРА ЧЕРЕПАХИ Команда Действия команды Значения Нов_цвет Меняет цвет черапашки и пишущего пера От 0 до 139 Нов_размер_пера Меняет толщину пишущего пера От 1 до 100 Нов_фон Меняет цвет фона От 0 до 139 ПАЛИТРА ЧЕРЕПАХИ Домашнее задание: 1. Выучить новые команды2. Составить программу для рисования Вертушки ПАЛИТРА ЧЕРЕПАХИ Практическая работа: Измените цвет фона в программе «Это треугольник»Измените цвет пера и размер пера в программах «Это треугольник», «Это пятиугольник», «Это шестиугольник», «Это круг»Сохраните проект с изменениями в своей папке Источники информации Основы информатики и вычислительной техники: Проб учеб. для сред. учеб. заведений А.Г Кушниренко, Г.В. Лебедев, Р.А. Сворень. – 2-е изд. – М.: Просвещение, 1991. Алгоритмы и исполнители © К.Поляков, 1992-2008Информатика. 7-9 кл.: Учеб. Для общеобразоват. Учреждений/А.Г. Гейн, А.И. Сенокосов, В.Ф. Шолохович. – М.: Дрофа, 2003.Владимирова Н.А. Азбука информатики в определениях. – Издательский дом «Первое сентября», № 14 2011.

Приложенные файлы

Добавить комментарий